Страниц: [1] 2 3 ... 10
 1 
 : 16 Января 2017, 14:31:41 
Автор abdula121 - Последний ответ от Sushi
Во первых посмотри у хостера настройки для сайтов, там может быть что-то в виде "использовать SSL или HTTPS для сайта". Если есть такая опция, то включи её.
Во вторых в wp-config.php убери define( 'FORCE_SSL_ADMI N', true );  и вместо этого поставь $_SERVER['HTTPS'] = 'on';
В третьих в файле .htaccess в корневом каталоге вставь строки
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Далее в базе майскуль в таблице префикс_options найди строки siteurl и home (они должны быть в самом начале) и замени значения http://мойсайт.ru на https://мойсайт.ru
Должно заработать.
Если всё работает, то пройдись по всей базе и функцией поиска и замены все http://мойсайт.ru поменяй на https://мойсайт.ru

 2 
 : 16 Января 2017, 14:19:35 
Автор abdula121 - Последний ответ от abdula121
Может кто поможет. Мне нужно сделать защищенное соединение ворд пресса для интернет магазина вукоммерц. Поменял в настройках админки Вордпресса адрес c http: на https: и все пропало. Вернее браузер выдает пустую страницу и пишет о большом количестве переадресаций. Как исправить.
Прочитал, что можно только админку перевести на ssl, т.е. на https, в конфиге прописал define( 'FORCE_SSL_ADMI N', true ); но это не помогает.

 3 
 : 16 Января 2017, 14:16:14 
Автор abdula121 - Последний ответ от abdula121
спасибо, заработало. Я уж думал сертификат покупать прийдется. Оказалось все просто. Сколько описаний и способов перепробовал, ничего не получалось.

 4 
 : 16 Января 2017, 11:51:33 
Автор abdula121 - Последний ответ от Sushi
Да, с бесплатным сертификатом SSL тоже можно работать. Правда ходят слухи, что когда большинство перейдёт на HTTPS, то бесплатные сертификаты отменят ((
Чтобы перевести форум на хттпс нужно:

в файле .htaccess указать следующие строки переадресации
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Затем скачать файл repair_setting s.php с сайта симплмашин http://download.simplemachines.org/index.php?thanks;filename=repair_settings.php
Кидаешь его в корневую папку сайта и запускаешь. Там для всех путей вместо http: ставишь https:
Вот и всё, должно всё заработать. Не забудь потом удалить файл repair_setting s.php

 5 
 : 13 Января 2017, 15:51:19 
Автор abdula121 - Последний ответ от abdula121
спасибо большое, помогло. Т.е. я вернул форум на прежние рельсы типа http://мойсайт.ру
Если не сложно, скажите как правильно перевести форум полностью на https, сертификат есть, правда он бесплатный. С бесплатным можно сделать адрес https ?

 6 
 : 13 Января 2017, 15:23:45 
Автор abdula121 - Последний ответ от Sushi
Отключить можно только из базы. Заходишь в таблицу префикс_settings, там находишь параметр force_ssl, у него стоит значение 2, нужно изменить его на ноль (0), тогда должен заработать.

 7 
 : 13 Января 2017, 15:04:35 
Автор abdula121 - Последний ответ от abdula121
Поставил новую версию smf 2.1 beta 2 и решил сразу перевести весь форум с http на https. Заказал сертификат на домен, в админке в меню Обслуживание - Общие в поле Forum SSL mode выбрал вместо Disable SSL значение Force SSL throughout the forum. Решил, что будет всё легко и просто. И тут бац и форум перестал работать. Т.е. белая страница везде и в админке и во фрондэнде. Чо я только не делал, зашёл в файл конфигурации, а там имя домена стоит с http. Но никакой браузер не открывает и ругается на безопасность и на многочисленные переадресации.
Как мне исправить ситуацию. Почему не работает SSL на форуме? Или как хотя бы отключить эту переадресацию в https?
Яндекс браузер пишет:
Сайт мойсайт.ru выполнил переадресацию слишком много раз. ERR_TOO_MANY_R EDIRECTS:
а Хром ещё и предлагает удалить куки. Удалял всё, весь кэш чистил, ничего не помогает.

Страниц: [1] 2 3 ... 10